Discussion Forums

Problems after install of ECU+

General questions and chit-chat about the ECU+.

Problems after install of ECU+

Postby Chicken Patty » Tue Jun 03, 2008 7:59 pm

Good day Everybody,

Yesterday, I installed the ECU+ on my car. IT came off my buddies 03 EVO 8. From my understanding it is the same wire up as the 2g DSM. However since I installed it most of the times I start the car whether cold or hot, it cranks up, and as the idle comes back down to settle it just goes really low, stutters and then goes back up and settles just fine. Sometimes it shuts off.

Another thing from time to time very randomly, its only done it like 2 or 3 times, the car would just get a random missfire for like 2 or 3 seconds and just go away. Anybody have any idea what this can be????

All the settings on the head unit seem to be right, the only thing that bothers me is that the MAF selection only said EVO 8, it did not give any more options. COuld that be the problem??

Any help is appreciated as I have not gave the money for this yet and am in time of returning it if defective or anything, my buddy is letting me try it out for a while to see if I decide to keep it.
Image
Chicken Patty
 
Posts: 4
Joined: Tue Jun 03, 2008 7:53 pm
Location: Miami, Florida

Postby tlcoll1 » Tue Jun 03, 2008 9:20 pm

The EVO model of the ECU+ isn't swappable into a DSM. That's why several of the drop-downs only let you select an EVO-related option.

Tom
tlcoll1
Site Admin
 
Posts: 1512
Joined: Sun Jun 13, 2004 1:01 am
Location: Odenton, MD

Postby Chicken Patty » Wed Jun 04, 2008 12:02 am

tlcoll1 wrote:The EVO model of the ECU+ isn't swappable into a DSM. That's why several of the drop-downs only let you select an EVO-related option.

Tom


anja. That explains it. Although the Maf selection seems to be the only thing that i cannot change to what it needs to be, everything else seems to be perfect. However can that be the cause of my problem? If so, wouldn't it be constant?
Image
Chicken Patty
 
Posts: 4
Joined: Tue Jun 03, 2008 7:53 pm
Location: Miami, Florida

Postby tlcoll1 » Wed Jun 04, 2008 12:47 am

Cam sensor type also comes to mind, and that'll cause the car to run like you mentioned. Also, the EVO version connects the clutch switch ECU+ wire to a pin on the stock ECU. That pin isn't the clutch switch on 2G DSMs (I don't actually know what it is). Hopefully, you haven't damaged the ECU+ head unit or your stock ECU.

Tom
tlcoll1
Site Admin
 
Posts: 1512
Joined: Sun Jun 13, 2004 1:01 am
Location: Odenton, MD

Postby Chicken Patty » Wed Jun 04, 2008 7:17 am

tlcoll1 wrote:Cam sensor type also comes to mind, and that'll cause the car to run like you mentioned. Also, the EVO version connects the clutch switch ECU+ wire to a pin on the stock ECU. That pin isn't the clutch switch on 2G DSMs (I don't actually know what it is). Hopefully, you haven't damaged the ECU+ head unit or your stock ECU.

Tom



hopefully, soon as I get off work, its coming off. Thank God I still have my s-afc, at least it'll be better than nothing for now. Thanks a lot for your support.

One thing before I drop this subject. I saw on your site you are not selling any more ECU+. Although, would it be possible that if I send you the hardware you can update it so that it works with my car?
Image
Chicken Patty
 
Posts: 4
Joined: Tue Jun 03, 2008 7:53 pm
Location: Miami, Florida

Postby tlcoll1 » Wed Jun 04, 2008 6:02 pm

I'm not doing any more hardware mods, so the only ECU+ option you have at this point is to buy a used DSM version. I think the DSM versions are kinda hard to find, though.

Tom
tlcoll1
Site Admin
 
Posts: 1512
Joined: Sun Jun 13, 2004 1:01 am
Location: Odenton, MD

Postby Chicken Patty » Wed Jun 04, 2008 6:33 pm

tlcoll1 wrote:I'm not doing any more hardware mods, so the only ECU+ option you have at this point is to buy a used DSM version. I think the DSM versions are kinda hard to find, though.

Tom


damn, we'll thanks a lot anyways. I'll see what I can do. Thanks for your support.
Image
Chicken Patty
 
Posts: 4
Joined: Tue Jun 03, 2008 7:53 pm
Location: Miami, Florida


Return to General Q&A

Who is online

Users browsing this forum: No registered users and 1 guest

cron