Discussion Forums

Installed 650 injectors...need advice

Car-specific questions and tuning advice for the 1995-1999 Turbo Talon and Eclipse cars.

Installed 650 injectors...need advice

Postby Silversurfermd » Tue Sep 09, 2008 4:34 pm

Hello everybody.

Been logging for a while but this is my first attempt at tuning fuel curves. I dropped in a rewire walboro 255 with FPR at 43.5 psi and FIC 650 and now the engine boggs/stutters/dies and backfires...and smells like gas. I know the wideband is not recorded (for some reason) but I managed to get it mostly 14.7 idle. These MAPs will hopefully give enough info of what I can improve on. Thanks for any help or example maps...

Sincerely Mike
Attachments
20080909-153359.ecd
Injector 650 with +40 Idle interpolated (feels/sounds better)
(106.22 KiB) Downloaded 311 times
20080909-152804.ecd
Injector 650 with +35 Idle interpolated
(220.85 KiB) Downloaded 285 times
Silversurfermd
Silversurfermd
 
Posts: 6
Joined: Sun Nov 18, 2007 12:57 pm

Re: Installed 650 injectors...need advice

Postby tlcoll1 » Mon Sep 15, 2008 9:53 pm

Mike -

The fuel maps look ok to me. You should do a long log of driving around and verify that your front O2 voltages are cycling in normal driving (one of the logs only contained 20 secs or so of data, so I can't tell) and at idle. Because the MUT-II fuel trims don't work on your car, I'd recommend looking at the OBD-II screen's fuel trims after driving to verify that they're small (indicating you're in the right ballpark for your non-WOT settings) and adjust accordingly. Also, I suggest the gradient style of fuel adjustments, which you have, but it's also possible that the idle value may be significantly different than what you'd expect from the gradient - that's ok. For WOT tuning, get that wideband figured out, and shoot for low 11:1 AFRs.

Tom
tlcoll1
Site Admin
 
Posts: 1511
Joined: Sun Jun 13, 2004 1:01 am
Location: Odenton, MD


Return to 2G DSM Specific

Who is online

Users browsing this forum: No registered users and 1 guest

cron