Discussion Forums

Your mods and tune

Car-specific questions and tuning advice for the Lancer Evolutions. EVO 8 and 9 mostly, but earlier models welcome.

Your mods and tune

Postby rogersmith » Mon Oct 22, 2007 1:24 pm

I was wonder what kind of mods and tunes you other evo owners are running. Like Honki, I saw you're using a MBC. What do you have it set to?

I don't really have my tune finalized because I'm still trying to fix my AVR firmware.

Car:
2003 Evo 8

For tune, planning to do:
24-25 psi spike at 3500
23-22 to 6000
21-19 7000+

Mods: Turbo-back, Tomei blow-off valve. Cusco Zero2E

I'm in California so I run 91 octane.

I'll post a ECU+ dyno sheet when I get my tune finalized (or close to).
rogersmith
 
Posts: 84
Joined: Fri Nov 24, 2006 5:28 pm

Postby honki24 » Tue Oct 23, 2007 11:17 am

Here's my mod list:
http://www.flatlinemotorsports.net/Vehicle_Data.php
I run 25psi on a Hallman in-car MBC. I believe it tapers down to 19-20ish by redline.

(be aware that if you're gonna run that much boost you need something supplimental [WI/AI] or run crazy low timing) I don't own a dyno so I don't know the direct tradeoff of timing/boost but I'd suspect that getting up into the 25psi range and giving up timing is less helpful than less boost w/ more timing since at that PR the stock turbo is heating up pretty good.

I could post up my ROM but I'm afraid too many will frag themselves by copy/pasting. If your interested you can PM me. I don't use ECU+ for general tuning, but rather for its amazing logging ability plus multiple inputs/outputs/extra abilities. Plus nothing else keeps my CEL on quite so consistantly ;) you know I heart you Tom!
Advoacate of the Theocratic Reign.
http://www.FlatlineMotorsports.net
03 Evo 8
honki24
 
Posts: 525
Joined: Thu Nov 17, 2005 9:59 am

Postby Sleeper8 » Wed Oct 24, 2007 9:41 am

I have a question why does your boost taper off. My boost stays at 20 psi all the way to redline. Is there a reson you have your boost taper like that.
Sleeper8
 
Posts: 18
Joined: Mon Oct 08, 2007 10:41 am

Postby rogersmith » Wed Oct 24, 2007 10:27 am

That's cool you got the Whiteline roll center adjust kit? Does the roll at initial turn in dramatic decrease? I've always been interested in getting that.

And Sleeper, boost will always taper with MBC. Anyways it's good to taper it because volumetric efficiency decreases as you get to redline.
rogersmith
 
Posts: 84
Joined: Fri Nov 24, 2006 5:28 pm

Postby Sleeper8 » Wed Oct 24, 2007 11:09 am

the only reson I ask was becuase my boost guage show 20 psi all the wayto redline, so how do i know what i am tapering off to?
Sleeper8
 
Posts: 18
Joined: Mon Oct 08, 2007 10:41 am

Postby rogersmith » Wed Oct 24, 2007 12:56 pm

You must be controlling boost through the ECU. No? To get flat 20 all the way to redline can only be done with ECU-controlled boost.
rogersmith
 
Posts: 84
Joined: Fri Nov 24, 2006 5:28 pm

Postby honki24 » Thu Oct 25, 2007 6:21 am

Yes, I get taper because of MBC. As a matter of a fact though, if you cranked up your boost w/ the stock solenoid, you will taper too. The turbo can't support greater than 20psi at redline so it will always taper down. You just so happen to have picked the maximum pressure that the turbo can sustain at redline, so you don't see taper, but then again you also don't see that 40hp bulge of power between 3500 and 5800 RPM caused by cranking it up either. :wink:

Yeah, the whiteline kit actually makes a noticeable difference on the track because my car is pretty significantly lowered. Turn in feels much more crisp like my sidewalls just got 300% more stiff. It took some getting used to for sure. You can't notice anything on the street.
Advoacate of the Theocratic Reign.
http://www.FlatlineMotorsports.net
03 Evo 8
honki24
 
Posts: 525
Joined: Thu Nov 17, 2005 9:59 am

Postby dWiGhT » Fri Nov 23, 2007 1:20 pm

Ok... I was with ya till you got to this part:
"I'm in California so I run 91 octane. "

Don't think you want to turn up the volumn on the boost over 21 with the cal91octPiss... or are you running meth/water injection???

dWiGhT
dWiGhT
 
Posts: 14
Joined: Tue Nov 20, 2007 8:38 am

Postby rogersmith » Thu Jan 17, 2008 4:16 pm

Yes, you're right. My MAP wasn't calibrated correctly. I'm now at 21-20.
rogersmith
 
Posts: 84
Joined: Fri Nov 24, 2006 5:28 pm


Return to EVO Specific

Who is online

Users browsing this forum: No registered users and 1 guest

cron